Why This Site Doesn't Work Properly?

#1
The site is too slow. Also my browser is unable to load most of the time, so I have keep refreshing it.

All other websites open smoothly so I don't think there is any problem with my net connection.
 

Alchemist

Administrator
Staff member
#3
The site is too slow. Also my browser is unable to load most of the time, so I have keep refreshing it.
Usually, the site works fine for me.

Try changing the browser and deleting the cookies and other temporary files.

What is your net speed?

The default posts per page setting is high for this site. That increases the load times for some threads.
 
#4
I've tried Chrome, Firefox and IE. Also I did clearing cache, etc. But still I have to refresh 5 times to open 1 webpage. My net speed is 1 mbps broadband of Reliance.

Also the threads that I've subscribed and made Instant Notification email settings, but still I don't receive emails. Any idea?
 

Alchemist

Administrator
Staff member
#5
I've tried Chrome, Firefox and IE. Also I did clearing cache, etc. But still I have to refresh 5 times to open 1 webpage. My net speed is 1 mbps broadband of Reliance.

Also the threads that I've subscribed and made Instant Notification email settings, but still I don't receive emails. Any idea?
My host has an hourly limit for outgoing emails.

I was hitting the limit every day and thus I disabled email notifications.

You problem may be related to your ISP.

Sometimes I face a similar problem when I try to access google.co.in.

Google.com keeps redirecting me to google.co.in, but google.co.in doesn't load for me and then I have to use google.co.uk to search.
 
Top